using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<cond>\{(\$|if|foreach).+\})(.|\n)?(\{end\k<cond>|)";
string input = @"{if $var == 0}
text
{endif}
{foreach $array as $key => $val}
{if $var == 1}{endif}
{endforeach}
{$var}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}