package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^[A-Z\d]+$`)
var str = `test
Test23
234!
asdf#@$(
test onetwo
asdf
onetwo123three`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}