$re = '/^-{2,}\s*(\w+(?:\s+\w+)*)\s*-{2,}$/';
$str = '-------- Variable used for recipe visualization only - Not loaded into PLC --------';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);