using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(-?\d+)(?:\.0+|(\.\d*?)0+|\.+)?$";
string substitution = @"$1$2";
string input = @"50.000
50
50.100
50.040
50.
50.000
=> 50
50.500
=> 50.5
-5
50";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}