$re = '/^(-?\d+)(?:\.0+|(\.\d*?)0+|\.+)?$/m';
$str = '50.000
50
50.100
50.040
50.
50.000
=> 50
50.500
=> 50.5
-5
50';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;