re = /(?<=)\{[^\}]*\}(?=)/im
str = '"This is the string and it contains {0} a few {1} sets of curly brackets"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end