$re = '/^.*[\/\\\\](?<FileNameWithoutExtension>.*)\.(.*)$/';
$str = '/Users/cmagnuson/Desktop/DemandwareLogs/error-blade0-0-appserver-20160329.log
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);