package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m);{1,3}$`)
var str = `;;;
ciao;;;
come;stai;oggi;
cucu;ciao;;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}