$re = '/^(?:.*\/)?1-[^\/]*\.js$/m';
$str = './home/1-ddd.js
./home/2-homed.js ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);