Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
is_granted\((\[(.*?)\])
/
gm
Input 1
1
New
excludeIf = "expr(object.job === null or not is_granted(['VIEW', object.job]))" excludeIf = "expr(object.job === null or not is_granted(['VIEW']))" excludeIf = "expr(not is_granted(['VIEW_TASKS, object.site']) and not is_granted(['SITE_PERMISSION_VIEW_TASKS', object.asset.getSite()]))", * excludeIf = "expr(not is_granted(['SITE_PERMISSION_NOTIFY_UPDATES']) and not is_granted(['OPERATIVE_PERMISSION_NOTIFY_UPDATES', object.job.getServiceProvider()]))", $this->type = strtolower(preg_replace('/([a-z])([A-Z])/', '$1_$2', $reflection->getShortName()));