import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{1,2}\\-\\d{1,2}\\-\\d{4}";
final String string = "srv-test-01.test.ru(192.168.100.100) VMware: Free space on datastore 02-12-2012 (percentage)\n"
+ "srv-test-01.test.ru(192.168.100.102) VMware: Free space on datastore 18-42-2402 (percentage)\n"
+ "srv-test-01.test.ru(192.168.100.103) VMware: Free space on datastore 49-12-2001 (percentage)\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}