// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d{1,2}\-\d{1,2}\-\d{4}").unwrap();
let string = "srv-test-01.test.ru(192.168.100.100) VMware: Free space on datastore 02-12-2012 (percentage)
srv-test-01.test.ru(192.168.100.102) VMware: Free space on datastore 18-42-2402 (percentage)
srv-test-01.test.ru(192.168.100.103) VMware: Free space on datastore 49-12-2001 (percentage)
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}