re = /(?:class="|\G(?!^))\s*\K[^\s"]+/
str = '<div class="main menu">element</div>
<div class="content"></div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end