re = /<!--(?!\s*(?:\[if [^\]]+]|<!|>))(?:(?!-->)(.|\n))*-->/m
str = '<!-- some comments 1 -->
<!-- 1.91 -->
<!--
//-->
<!-- -->
<!--[if IE]> <![endif]-->
<!--[if !IE]><!--> <!--<![endif]-->
<!--[if IE 6]> <![endif]-->'
# Print the match result
str.match(re) do |match|
puts match.to_s
end