package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+,?\d{0,2}$`)
var str = `1
12
12,
12,3
12,34
12,456`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}