#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:a(?=a*(\1?+b)b*(\2?+c)))+\1\2$" & @CRLF & _
""
Local $sString = "aaabbbccc" & @CRLF & _
"abc" & @CRLF & _
"ab" & @CRLF & _
"aaabbbcc" & @CRLF & _
"aaaabbbbcccc" & @CRLF & _
"aabbbb"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")