package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\{\$[a-zA-Z0-9._+%]+\}`)
var str = `Obsahová symbolika
{$nadpish21} - nadpis h1 - h6, 1 - 128
{$htmltext21} - html text 1 - 128
{$plaintext1} - čistý text 1 - 128
{$arturl} - url daného konkrétního článku
{$pageurl1} - url vybraného článku, 1 - 128`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}