import re
regex = re.compile(r"(?P<name>post|get|url)\:(?P<data>(?:.(?!(et\:)|(ost\:)|(rl\:)))+)", flags=re.DOTALL)
test_str = ("dfkjsfkj dskljsdlfm sdfkjdsf sfsd get\n\n"
"asdkljasd,laosid post: \n"
"в\n"
"get:787wesdjdddddddddddddd hfsdfnxczp\n\n"
"url: oiwerweroi;get:787wesdjhfsdfnxczp")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")