#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^"?testing ((?!L?"?$).*?)"?$"
Local $sString = "testing rest" & @CRLF & _
" -> matches (rest)" & @CRLF & _
"testing what"" & @CRLF & _
""testing what"" & @CRLF & _
" -> matches (what)" & @CRLF & _
"testing Loong" & @CRLF & _
"testing Loong"" & @CRLF & _
" -> matches (Loong)" & @CRLF & _
"testing N" & @CRLF & _
""testing N"" & @CRLF & _
" -> " & @CRLF & _
"testing L" & @CRLF & _
"testing L"" & @CRLF & _
" -> this is not matched" & @CRLF & _
"testing" & @CRLF & _
" -> this is not matched" & @CRLF & _
"testing " & @CRLF & _
"-> this is not matched"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")