using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^""?testing ((?!L?""?$).*?)""?$";
string input = @"testing rest
-> matches (rest)
testing what""
""testing what""
-> matches (what)
testing Loong
testing Loong""
-> matches (Loong)
testing N
""testing N""
->
testing L
testing L""
-> this is not matched
testing
-> this is not matched
testing
-> this is not matched";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}