$re = '/^"?testing ((?!L?"?$).*?)"?$/m';
$str = 'testing rest
-> matches (rest)
testing what"
"testing what"
-> matches (what)
testing Loong
testing Loong"
-> matches (Loong)
testing N
"testing N"
->
testing L
testing L"
-> this is not matched
testing
-> this is not matched
testing
-> this is not matched';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);