re = /^"?testing ((?!L?"?$).*?)"?$/m
str = 'testing rest
-> matches (rest)
testing what"
"testing what"
-> matches (what)
testing Loong
testing Loong"
-> matches (Loong)
testing N
"testing N"
->
testing L
testing L"
-> this is not matched
testing
-> this is not matched
testing
-> this is not matched'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end