import Foundation
let pattern = #"^"?testing ((?!L?"?$).*?)"?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
testing rest
-> matches (rest)
testing what"
"testing what"
-> matches (what)
testing Loong
testing Loong"
-> matches (Loong)
testing N
"testing N"
->
testing L
testing L"
-> this is not matched
testing
-> this is not matched
testing
-> this is not matched
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)