#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "{"name":"[^"]*","id":"([^"]*)","type":"([^"]*)","available":true,[^{}]*}"
Local $sString = "{"error":null,"data":{"airports":[],"pocs":[],"regions":[{"name":"Central America","id":"L04305","type":"CruiseArea","available":false,"countries":"Mexico","group":null},{"name":"Caribbean","id":"L04304","type":"CruiseArea","available":false,"countries":"St Maarten,Barbados,British Virgin Islands,St Kitts and Nevis,St Vincent and the Grenadines,Antigua","group":null},{"name":"Western Mediterranean","id":"L34381","type":"CruiseArea","available":true,"countries":"Spain","group":null},{"name":"Eastern Mediterranean","id":"L34373","type":"CruiseArea","available":false,"countries":"Greece,Italy,Slovenia,Montenegro,Croatia","group":null},{"name":"North Africa And Middle East","id":"L04301","type":"CruiseArea","available":false,"countries":"Morocco","group":null},{"name":"Fjords, Iceland And Arctic","id":"L34384","type":"CruiseArea","available":true,"countries":"Norway","group":null},{"name":"Northern Europe And UK","id":"L34383","type":"CruiseArea","available":true,"countries":"United Kingdom","group":null}],"countries":[{"name":"Spain","id":"ESP","type":"COUNTRY","available":true,"countries":null,"group":null},{"name":"Jamaica","id":"JAM","type":"COUNTRY","available":false,"countries":null,"group":null},{"name":"Greece","id":"GRC","type":"COUNTRY","available":false,"countries":null,"group":null},{"name":"Italy","id":"ITA","type":"COUNTRY","available":false,"countries":null,"group":null},{"name":"Turkey","id":"TUR","type":"COUNTRY","available":false,"countries":null,"group":null},{"name":"Barbados","id":"BRB","type":"COUNTRY","available":false,"countries":null,"group":null},{"name":"Mexico","id":"MEX","type":"COUNTRY","available":false,"countries":null,"group":null},{"name":"Israel","id":"ISR","type":"COUNTRY","available":false,"countries":null,"group":null},{"name":"Cuba","id":"CUB","type":"COUNTRY","available":false,"countries":null,"group":null},{"name":"Croatia","id":"HRV","type":"COUNTRY","available":false,"countries":null,"group":null}],"itineraries":[],"airportGroups":[]},"nomatch":false,"durations":null,"searchError":null}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")