using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"HELLO: ([^|]+)";
string input = @"THIS IS MY EXAMPLE|OTHER EXAMPLE|HELLO: Kevin|OTHER EXAMPLE|OTHER EXAMPLE";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}