using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*?(Found no active cells!|CellId(.*\n)*.*))|(uehId:.*)";
string input = @"FXL260> ue print -admitted
Trying rbs's password from uservariable com_password ...OK
....
190830-12:11:22 10.86.28.138 19.0g stopfile=/tmp/74752
coli>/lrat/ue print -admitted
CellId #UE:s #Bearers
1 53 72
2 9 14
3 38 52
101 0 0
102 0 0
103 0 0
coli>
";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}