# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*?(Found no active cells!|CellId(.*\n)*.*))|(uehId:.*)"
test_str = ("FXL260> ue print -admitted\n"
"Trying rbs's password from uservariable com_password ...OK\n"
"....\n"
"190830-12:11:22 10.86.28.138 19.0g stopfile=/tmp/74752\n"
"coli>/lrat/ue print -admitted\n"
"CellId #UE:s #Bearers \n"
" 1 53 72\n"
" 2 9 14\n"
" 3 38 52\n"
" 101 0 0\n"
" 102 0 0\n"
" 103 0 0\n"
"coli>\n")
matches = re.search(regex, test_str, re.DOTALL | re.IGNORECASE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.