# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=h.llo )[A-Za-z]+/world/gm;t' <<< "hello everyone, hullo anything"