import re
regex = re.compile(r"(?<=h.llo )[A-Za-z]+", flags=re.MULTILINE)
test_str = "hello everyone, hullo anything"
subst = "world"
result = regex.sub(subst, test_str)
if result:
print(result)