re = /\d\d (\d\d):(\d\d):.*\R.* (?!\1)\d+:\2/m
str = '2024-01-19 13:09:22.616 Message="one"
2024-01-19 13:09:22.721 Message="two"
2024-01-19 14:09:22.814 Message="three"
2024-01-19 13:09:22.902 Message="four"'
# Print the match result
str.scan(re) do |match|
    puts match.to_s
end