import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=,\\s*)(?:([A-Z])\\.?[a-üA-Z\\{\\\\'\\}]*(?:(-)| )?)(?:([A-Z])(\\.?)[a-üa-zA-Z\\{\\\\'\\}]*(?:(-)| )?)?(?:([A-Z])(\\.)?[a-zA-Z\\{\\\\'\\}]*(?:(-)| )?)?(?= and|$)";
final String string = "Copiez votre liste d'auteur ici. Elle doit être sous la forme\n\n"
+ "Bennett, Elena M. and Baird, Julia and Baulch, Helen and Chaplin-Kramer, Rebecca and Fraser, Evan and Loring, Phil and Morrison, Peter and Parrott, Lael and Sherren, Kate and Winkler, Klara J. and Cimon-Morin, Jérôme and Fortin, Marie-Josée and Kurylyk, Barret L. and Lundholm, Jeremy and Poulin, Monique and Rieb, Jesse T. and Gonzalez, Andrew and Hickey, Gordon M. and Humphries, Murray and Krishna {Bahadur KC} and Lapen, David\n\n"
+ "Certain prénoms composés (ici Ruel, Jean-Claude) doivent être terminé à l'aide du deuxième outil: \n\n";
final String subst = "$1.$2$3$4$5$6$7";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}