import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "problem path:.+";
final String string = "here is one line\n"
+ "problem path: path1\n"
+ "another line\n"
+ "value line more info\n"
+ "value\n"
+ "problem path: path2\n"
+ "incredible data line\n"
+ "problem path: path3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}