#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(.*?(\bdocbox\b.*.pdf).+)$"
Local $sString = "Failed to move from wasbs:///docbox/7391167/26988/service_report/EDINBURGH CLINIC LTD_999002225876_20121019.pdf/2022-02-07 18:53:41.pdf to wasbs:///docbox/7391167/26988/service_report/2022-02-07 18:53:41/EDINBURGH CLINIC LTD_999002225876_20121019.pdf"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)