#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([^\\\n]*(?:\\\\)*)\*"
Local $sString = "*" & @CRLF & _
"\*" & @CRLF & _
"\\*" & @CRLF & _
"\\\*" & @CRLF & _
"\\\\*"
Local $sSubst = "$1%"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)