// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\{[^|}]++\|([^|}]++)(?:\|[^|}]++)*\}").unwrap();
let string = "{Feel free to|Twenty-four hours a day|Do|Then|You can} stop on by, or {contact us|e mail us|call us|e-mail us|email us} about {your needs|your requirements|your preferences|the needs you have|your family needs}. {We look forward|Good quality} to {hearing from|talking with|listening to|meeting up with} you!";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}