use strict;
my $str = 'test.output0 testx.testj.output1 output3 testds.no.output2 ';
my $regex = qr/.*?\.?(\w+)(?=\t)/mp;
my $subst = '$1\\t';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";