use strict;
my $str = 'my-valid-self-signed-cert
myvalidcert
myInvalidCert
-my-invalid-self-signed-cert
my-invalid-self-signed-cert-
my-invalid--self-singed-cert
';
my $regex = qr/^[a-z]+(-?[a-z]){0,63}-?[a-z]+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}