#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(\bbod\S*)|(embodi\S*)"
Local $sString = "Fancher: what does Eugene teach us about embodiment (for disembodied chatter bot) and intelligence? #RSA16" & @CRLF & _
"" & @CRLF & _
"Faris: And in spite of turns to embodiment and sensation, little on eros of bodies #o15 #rsa16" & @CRLF & _
"" & @CRLF & _
"Kerschbaum: Embodiment and embodied knowledge is always embedded with our decisions and navigations of spaces. #rsa16" & @CRLF & _
"" & @CRLF & _
"#yesallwomen shows digital embodiment through storytelling. #g19 #RSA16 @RCMeg" & @CRLF & _
"" & @CRLF & _
"Virtual is an extension of the corporeal body. We must pay attention to movement. To embodiment. #RSA16 #g19" & @CRLF & _
"" & @CRLF & _
"#i5 #RSA16 @DrJenTalbot parrhesia assumes static notions of embodiment and power"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")