use strict;
my $str = 'Fancher: what does Eugene teach us about embodiment (for disembodied chatter bot) and intelligence? #RSA16
Faris: And in spite of turns to embodiment and sensation, little on eros of bodies #o15 #rsa16
Kerschbaum: Embodiment and embodied knowledge is always embedded with our decisions and navigations of spaces. #rsa16
#yesallwomen shows digital embodiment through storytelling. #g19 #RSA16 @RCMeg
Virtual is an extension of the corporeal body. We must pay attention to movement. To embodiment. #RSA16 #g19
#i5 #RSA16 @DrJenTalbot parrhesia assumes static notions of embodiment and power';
my $regex = qr/(\bbod\S*)|(embodi\S*)/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}