// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(\bbod\S*)|(embodi\S*)").unwrap();
let string = "Fancher: what does Eugene teach us about embodiment (for disembodied chatter bot) and intelligence? #RSA16
Faris: And in spite of turns to embodiment and sensation, little on eros of bodies #o15 #rsa16
Kerschbaum: Embodiment and embodied knowledge is always embedded with our decisions and navigations of spaces. #rsa16
#yesallwomen shows digital embodiment through storytelling. #g19 #RSA16 @RCMeg
Virtual is an extension of the corporeal body. We must pay attention to movement. To embodiment. #RSA16 #g19
#i5 #RSA16 @DrJenTalbot parrhesia assumes static notions of embodiment and power";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}