$re = '/^(.*?)\s(dk\d+)\s(.*?)\s(\d+)/';
$str = 'CVR-nr. dk30344510 / Tlf. 62226420';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);