#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^.*?Python Regular Expression.*?$(*SKIP)(*FAIL)|^.*?Python Proprietary.*?$(*SKIP)(*FAIL)|.*?Page \d+.*?$(*SKIP)(*FAIL)|^$(*SKIP)(*FAIL)|^.*?$"
Local $sString = "This module provides regular expression matching operations." & @CRLF & _
"" & @CRLF & _
"Regular expressions use the backslash character ('\') to indicate special forms" & @CRLF & _
"or to allow special characters to be used without invoking their special" & @CRLF & _
"meaning." & @CRLF & _
"" & @CRLF & _
"Python Regular Expression 02 December 1999 " & @CRLF & _
"" & @CRLF & _
" Python Proprietary " & @CRLF & _
"" & @CRLF & _
"----------------------- Page 292-----------------------" & @CRLF & _
"" & @CRLF & _
"PYTHON RE SPECIFICATION Version 2.7 [Vol 9, Part Q] page 983 " & @CRLF & _
"" & @CRLF & _
"Python Regular Expression Specification " & @CRLF & _
"" & @CRLF & _
"It is important to note that most regular expression operations are available as" & @CRLF & _
"module-level functions and RegexObject methods. The functions are shortcuts that" & @CRLF & _
"don’t require you to compile a regex object first, but miss some fine-tuning" & @CRLF & _
"parameters."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")