#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?!.{0,7}[DFIOQU])[A-VXY]\d[A-Z][^-\w\d]\d[A-Z]\d\b"
Local $sString = "Valid" & @CRLF & _
"123 4th Street, Toronto, Ontario, M1A 1A1" & @CRLF & _
"12456 Pine Way, Montreal, Quebec H9Z 9Z9" & @CRLF & _
"Invalid" & @CRLF & _
"123 4th Street, Toronto, Ontario, Q1A 1A1" & @CRLF & _
"12456 Pine Way, Montreal, Quebec H9Z-9Z9" & @CRLF & _
"56 Winding Way, Thunder Bay, Ontario, D56 4A3" & @CRLF & _
"34 Cliff Drive, Bishop's Falls, Newfoundland B7E 4T" & @CRLF & _
"123 4th Street, Toronto, Ontario, M1A 1Q1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")