#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)class\s(\w+)|def\s(\w+)"
Local $sString = "class MyClass_1(...):" & @CRLF & _
" ..." & @CRLF & _
" def method1_of_first_class(self):" & @CRLF & _
" ..." & @CRLF & _
"" & @CRLF & _
" def method2_of_first_class(self):" & @CRLF & _
" ..." & @CRLF & _
"" & @CRLF & _
" def method3_of_first_class(self):" & @CRLF & _
" ..." & @CRLF & _
"" & @CRLF & _
"class MyClass_2(...):" & @CRLF & _
" ..." & @CRLF & _
" def method1_of_second_class(self):" & @CRLF & _
" ..." & @CRLF & _
"" & @CRLF & _
" def method2_of_second_class(self):" & @CRLF & _
" ..." & @CRLF & _
"" & @CRLF & _
" def method3_of_second_class(self):" & @CRLF & _
" ..."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")