import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:SELECT\\s++(?=(?:[#\\w,`.]++\\s++)+)|(?!^)\\G\\s*+,\\s*+(?:`?+\\s*+[#\\w]++\\s*+`?+\\s*+\\.\\s*+)?+`?+\\s*+)(\\w++)`?+(?:\\s++as\\s++[^,\\s]++)?+";
final String string = "SELECT columnA, columnB as foo, table.column8, table.column3 as foo, \n"
+ " `column7`, `column4` as foo, `table`.`columnZ`, `#__table`.`columnF` as foo FROM datable where\n\n"
+ "Select column1, column2 From table\n\n"
+ "select column0 from table";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}