re = /(\[.*?])\|(.*)\|(Description:.*)/
str = '[Testing.User]|Info:([Testing.Info]|Name:([System.String]|Matt)|Age:([System.Int32]|21))|Description:([System.String]|This is some description)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end