#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "("[^"\n]*)\r?\n(?!(([^"]*"){2})*[^"]*$)"
Local $sString = ""abc","def " & @CRLF & _
" ghi","klm " & @CRLF & _
"pqr", "xyz"" & @CRLF & _
""123","sdfsdf","sdfs"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "$1<br>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)