package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\w*\(\w*(?:,\w*)*\)`)
var str = `baz(uint32,,bool)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}