# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^(?<barCodeId>\d{2})(?<serviceType>\d{3})(?<mailerId>\d{6})(?<uniqueSequence>\d{9})(?<dpbc>.{11}))"
test_str = ("0014120556239013447647712510026\n"
"0014120556239013447747712556417\n"
"0014120556239013447847712504124\n"
"0014120556239013447947712500422\n"
"0014120556239013448047712482006\n"
"0014120556239013448147712494417\n"
"0014120556239013448247712935544\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.