re = /^(?:\d*,[^,]*,\d*,(?:true|false)\|?)+(?<!\|)$/m
str = '253,RFTL 9984.0,588,false|545,kajfkaj,988,true
253,RFTL 9984.0,588,false||545,kajfkaj,988,true
253,RFTL 9984.0,588,false|545,kajfkaj,988,true|
253,RFTL 9984.0,588,false|545,kajfkaj,988,true|545,kajfkaj,988,true'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end